23 октября, вторник 23:09
Bankir.Ru

Объявление

Свернуть
Пока нет объявлений.

Diebold ECKI проблема

Свернуть
X
  • Фильтр
  • Время
  • Показать
Очистить всё
новые сообщения

  • Diebold ECKI проблема

    Всем привет!
    Возникла такая проблема. Установили банкомат, залили его софтом
    Банкомат 1071ix OS/2 CTP G4. При загрузке не стартует TCS и вылетает ошибка OSKernel error. Error in piiom.app ....
    В TCS Setup отключили Lead Throw Indicators - стал запускаться.
    Обнаружили что не работает клавиатура ( не ЕПП4 ). Диагностика не неходит устройства вообще.
    На контроллере ECKI при старте загорается индикатор D2, а при запуске CSS моргает вместе с D1. В нормальном варианте должны моргать D3 и D2. Поставили новый контроллер, но на этом при старте CSS вообще ни один индикатор не моргает.
    Стали прозванивать ExpressBus и вроде как выяснили, что на контроллер не доходит сигнал DATAB. Взяли аналогичный разьем на контроллере принтеров - там если звонить между большим черным разьемом ( на АТМ адаптере ) и ним- короткое по DATA_A и DATA_B есть - все путем.
    Вопрос: Можно ли кинуть провод напрямую от разьема ATM адаптера на разьем контроллера клавы по сигналу DATA_B ? Или же эту соплю можно бросить от любого DATA_B в верхней части банкомата?

  • #2
    У людей проблема решилась. Оказывается, что дело было не в Express Bus, сигналах и т.д. Дело было в самом ECKI. Все контроллеры, которые туда ставили были одного типа и не работали. У них на плате между микрухой Philips и микрухой, вставляемой в колодку стояла микросхема Samsung. Нашли плату, на которой микросхема другая - точную маркировку не сказали, но там выгравирована что-то типа птицы Вообщем с ней все нормально пошло.

    Кто что может сказать по этому поводу. Ситуация еще более затемнилась

    Комментарий


    • #3
      Может быть у вас в TCS Setup прописана EPP клавиатура?

      Комментарий


      • #4
        Сообщение от zhdanick
        Может быть у вас в TCS Setup прописана EPP клавиатура?
        Извините, но я себя полным идиотом не считаю
        Нет там никакой ЕПП4 и прописано было все что нужно.

        Комментарий


        • #5
          Zhorik похоже, то ли якась фигня с уровнями сигналов, то ли с проводкой - какой-то из data коротнуло на землю или нет контакта. expressbus - это rs422, dataA, dataB, resetA, resetB - это диффренциальные пары. кинуть перемычку можно, там топология общая шина. все разъемы паралельны, кроме диспенсера.

          Комментарий


          • #6
            Сообщение от doctor64
            Zhorik похоже, то ли якась фигня с уровнями сигналов, то ли с проводкой - какой-то из data коротнуло на землю или нет контакта. expressbus - это rs422, dataA, dataB, resetA, resetB - это диффренциальные пары. кинуть перемычку можно, там топология общая шина. все разъемы паралельны, кроме диспенсера.
            Да уже разобрались, что дело не в Express Bus, а в самой плате. Причем переставляли Flash с другой платы, тоже не помогло. Сегодня поеду и поставлю нулячую платы с новой флэшкой. Потом напишу, если получится.

            Комментарий


            • #7
              Поставил новую плату - все заработало. Старую отправим в сервис-центр, может отремонтируют.

              Комментарий


              • #8
                Zhorik Ну, по описанию похоже входные буфера/преобразователи выгорели.

                Комментарий

                Пользователи, просматривающие эту тему

                Свернуть

                Присутствует 1. Участников: 0, гостей: 1.

                Обработка...
                X