3 декабря, четверг 01:34
Bankir.Ru

Объявление

Свернуть
Пока нет объявлений.

Генератор сроков отчетности

Свернуть
X
  • Фильтр
  • Время
  • Показать
Очистить всё
новые сообщения

  • Генератор сроков отчетности

    Подскажите, пожалуйста, есть ли программа, формирующая ежемесячный график представления форм отчетности в Банк России (с учетом периодической отчетности). Я не являюсь банковским работником, преподаю офисные технологии в вузе и предполагаю разработку программы в MS Excel для целей обучения VBA

  • #2
    Есть, в Excel, на этом форуме.

    Комментарий


    • #3
      Искала, не нашла. Подскажите, пожалуйста, критерии поиска.

      Комментарий


      • #4
        http://bankir.ru/dom/threads/67027-%...82%D0%BE%D0%B2

        Комментарий


        • #5
          график отчетности

          Спасибо!

          Комментарий


          • #6
            чот слепой чтоле - не вижу там файла - хотя обсуждение есть

            Комментарий


            • #7
              видимо так и есть.
              в последнем посте вложение
              http://bankir.ru/dom/threads/67027-%...=1#post3090169

              Комментарий


              • #8
                На ЦБшном FTP-сервере есть справочник \Spravoch\HD_LIST.ARJ
                Я открываю DBF-файл в екселе,
                беру из него часть столбцов

                ID DAY_TYPE DAY_WEEK DAY_DAT NOTE № раб. дня План Отметка о вып. 2016 г.
                Январь 1274111 N Пятница 01.01.2016 Новогодние каникулы =ЕСЛИ(E2=ДАТА(ГОД(E2);МЕСЯЦ(E2);1);ЕСЛИ(КОДСИМВ(C2)=78; 0; 1);ЕСЛИ(КОДСИМВ(C2)=78; G1; G1+1)) <заполняем вручную> <отмечаем карандашом> <отмечаем карандашом>
                1274112 N Суббота 02.01.2016 Новогодние каникулы =ЕСЛИ(E3=ДАТА(ГОД(E3);МЕСЯЦ(E3);1);ЕСЛИ(КОДСИМВ(C3)=78; 0; 1);ЕСЛИ(КОДСИМВ(C3)=78; G2; G2+1)) <заполняем вручную> <отмечаем карандашом> <отмечаем карандашом>
                Еще условное форматирование включено: если выходной - строчка цветная.

                Не нашел ранее на этом форуме файлика с макросами, если б его дополнить справочником выходных...

                Вобщем, на настоящий момент в обоих вариантах есть ручной труд: в примере от CAP - вбивать праздники, в моем - расставлять номера отчетов

                Комментарий


                • #9
                  в свое время в VBA Excel формировала такой график. Сравнение с указанным по ссылке файлом дает расхождения (подскажите, пож., как прикрепить файл)
                  Нажмите на изображение для увеличения. 

Название:	graf_сравнение.jpg 
Просмотров:	1 
Размер:	84.0 Кб 
ID:	4168084

                  Комментарий


                  • #10
                    Может быть кому-то пригодится этот подход, когда надо определить: является ли конкретная дата рабочим днем в России?
                    Нужен справочник HD_LIST.DBF, см. комментарии к этому cmd-файлу
                    Код:
                    @echo off
                    rem Проверка, является ли заданный день рабочим либо выходным
                    rem Справочник выходных дней HD_LIST.DBF с помощью Excel преобразован в текстовый файл vyhodnye.txt
                    rem W - work (рабочий); N - не рабочий (суббота, воскресенье, российский праздник, перенос выходного дня)
                    
                    rem Из двух последующих строк одна должна быть закомментирована
                    rem SET "checkdate=29.01.2017"
                    SET checkdate=%DATE%
                    
                    Set infile=vyhodnye.txt
                    
                    rem Сначала находим строку с заданной датой, содержимое строки записываем в переменную
                    for /F "tokens=*" %%i in (' find  /i "%checkdate%"  %infile% ') do set "simbolwork=%%i"
                    rem Из всей этой строки нас интересует только 19-й символ: W или N.
                    set "simbolwork=%simbolwork:~19,1%"
                    echo %simbolwork%
                    if %simbolwork%==. (echo В справочнике ЦБ дата %checkdate% отсутствует)
                    if %simbolwork%==W (echo По справочнику ЦБ %checkdate% - рабочий день)
                    if %simbolwork%==N (echo По справочнику ЦБ %checkdate% - выходной день)
                    pause
                    фрагмент текстового файла:
                    Код:
                    ID    ISO_DIG    ISO_LAT2    ISO_LAT3    DAY_TYPE    DAY_WEEK    DAY_DAT    NOTE
                    718806    643    RU    RUS    N    Пятница    01.01.2010    Новогодние каникулы
                    718807    643    RU    RUS    N    Суббота    02.01.2010    Новогодние каникулы
                    718808    643    RU    RUS    N    Воскресенье    03.01.2010    Новогодние каникулы
                    ***
                    1182859    643    RU    RUS    N    Суббота    30.12.2017    
                    1182860    643    RU    RUS    N    Воскресенье    31.12.2017
                    Последний раз редактировалось AndreyLu; 31.01.2017, 16:48.

                    Комментарий

                    Обработка...
                    X